日天A3主图(通达信公式 主图 源码 测试图)(图文)

时间:2020-01-13 22:35:41 作者:admin
后台-系统-系统设置-扩展变量-(内容页告位1-手机版)

软件介绍

 

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26); 

DEA:=EMA(DIFF,9);

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));

K:=SMA(RSV,9,3);

D:=SMA(K,9,3);

J:=3*K-2*D;

A:=CROSS(DIFF,DEA) AND CROSS(K,D) AND CROSS(J,D) AND DIFF<0;

A7:=FILTER(A,20);

DRAWTEXT(A7,L*0.999,'↑金振'),COLOR0000FF;

SA:=CROSS(DEA,DIFF) AND CROSS(D,K) AND CROSS(D,J) AND DIFF>0;

A8:=FILTER(SA,20);

DRAWTEXT(A8,H,'↓死振'),COLORWHITE;

{分析家公式网WWW.88GS.COM}

DRAWKLINE(H,O,L,C);

G1:=DIFF>REF(DIFF,1) AND DEA>REF(DEA,1);

G2:=DIFF<REF(DIFF,1)AND DEA<REF(DEA,1);

RSV1:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;

K1:=SMA(RSV1,5,1);

E1:=SMA(K1,3,1);

J1:=3*K1-2*E1;

F1:=EMA(J1,12);

F2:=REF(F1,1);

HH:=HHV(HIGH,3);

 LL:=LLV(LOW,3);

 HH1:=BARSLAST((HH  >  REF(HH,1)));

 LL1:=BARSLAST((LL  <  REF(LL,1)));

AA1:=(3*C+H+L+O)/6;

VAR1:=(8*AA1+7*REF(AA1,1)+6*REF(AA1,2)+5*REF(AA1,3)+4*REF(AA1,4)+3*REF(AA1,5)+2*REF(AA1,6)+REF(AA1,8))/36;

VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;

VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;

VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;

VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;

VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;

DRAWBAND(VAR1,RGB(80,50,50),VAR6,RGB(250,250,0));

C1:VAR1,COLORYELLOW,LINETHICK1;

C2:VAR6,COLORGREEN,LINETHICK2;

C3:IF(VAR1>VAR6 AND VAR6>=REF(VAR6,1),VAR6,DRAWNULL),COLORRED,LINETHICK2;

P2:EMA(CLOSE,50),COLORGREEN,LINETHICK3;

IF(P2>REF(P2,1), P2,DRAWNULL),COLORRED,LINETHICK3;

多:= CROSS(VAR1>VAR6,0.5) AND CROSS(LL1,HH1);

多1:=BARSLAST(REF(多,1));

多2:=C>REF(C,多1+1) AND 多;

多3:=FILTER(多2,20) AND P2>REF(P2,1);

DRAWTEXT(多3  ,LL,'↑多  ');

空:=CROSS(CROSS(HH1,LL1),0.5) ; 

空1:=BARSLAST(REF(空,1));

空2:=C<REF(C,空1+1) AND 空;

空3:=FILTER(空2,20)AND  CROSS(VAR1=VAR6,0.5);

DRAWTEXT(空3  ,HH,'↓空'),COLORYELLOW;

BDGD:=C=HHV(C,M);

GDSJ:=BARSLAST(FILTER(CROSS(0.08,BDGD),M1))+1;

GD:REF(H,GDSJ),COLOR00FF00,POINTDOT,LINETHICK1;

TPP:=CROSS(C,REF(GD,1)),COLOR0000FF,POINTDOT,LINETHICK0;

STICKLINE(GDSJ<=6,GD,GD,8,0),COLOR0000FF;

BDDD:=C=LLV(C,N);

DDSJ:=BARSLAST(FILTER(CROSS(0.08,BDDD),N1))+1;

DD1:REF(L,DDSJ),COLORYELLOW,POINTDOT,LINETHICK1;

STICKLINE(DDSJ<=6,DD1,DD1,8,0),COLORYELLOW;

DRAWICON(DDSJ,L,1);

LC:=REF(CLOSE,1);

WRSI:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;

XG10:=CROSS(20,WRSI);

XGT4:=BARSLAST(XG10);

AD4:=REF(L,REF(XGT4,1)+1);

XG11:=REF(XGT4,1)>20 AND XG10 ; 

DRAWICON(XG11,L,38);

ZS:=REF(CLOSE,1); 

QS:=SMA(MAX(CLOSE-ZS,0),8,1)/SMA(ABS(CLOSE-ZS),8,1)*100,COLOR0080FF,LINETHICK2;

XX:=20; 

SS:=80; 

ZZ:=50;

XG1:=CROSS(80,QS) ;

XG2:=CROSS(QS,15);

 XG3:=CROSS(QS,19);

D1:=FILTER(XG1,10);

D2:=FILTER(XG2,10);

D3:=FILTER(XG3,10);

STICKLINE(D1 AND C<O,C,O,3.6,0 ),COLOR00FFFF;

 STICKLINE(D3 AND C>O,C,O,3.6,0 ),COLORFF00FF;

DRAWICON(D2,L*0.999,25);

XGT2:=BARSLAST(XG1);

AD2:=REF(L,REF(XGT2,1)+1);

XG6:= REF(XGT2,1)>10 AND XG1 ;

XGT3:=BARSLAST(XG2);

AD3:=REF(L,REF(XGT3,1)+1);

XG8:= REF(XGT3,1)>20 AND XG2;

BB32: IF(BARSLAST(XG6)<=30 

AND (REF(H,BARSLAST(XG6)))=REF(REF(H,BARSLAST(XG6)),1)

,REF(H,BARSLAST(XG6)),DRAWNULL)DOTLINE,COLORMAGENTA;

DRAWICON(XG6,H*1.001,2);

DRAWICON(XG8,L,1);

A5:=3*SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,21,1)-2*

SMA(SMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100,20,1),8,1);

AQW:=20;

ZQ:=CROSS(A5,AQW);

ZQ2:=FILTER(ZQ,20);

DRAWTEXT(ZQ2,L*0.999,'↑转'),COLOR0000FF;

VAR21:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;

VAR22:=SMA(VAR21,3,1);

VAR23:=SMA(VAR22,3,1);

VAR24:=SMA(VAR23,3,1);

波:= VAR23;

段:= VAR24;

VAR26:=CROSS(VAR23,VAR24) AND VAR23<20;

CD:=FILTER(CROSS(VAR23,VAR24),10) ;

A26:=HH1>LL1;

VAR27:=CROSS(VAR24,VAR23) AND VAR23>80;

小顶:=FILTER(VAR27,5) AND C<VAR6  AND A26 AND NOT(VAR1>VAR6);

DRAWTEXT(小顶  ,HH,'↓空'),COLORGREEN;

VAR13:=REF(CLOSE,1);

VAR14:=((SMA(MAX((CLOSE - VAR13),0),17,1) / SMA(ABS((CLOSE - VAR13)),17,1)) * 100);

空4:=CROSS(80,VAR14);

高:=FILTER(空4,10); 

DRAWTEXT(高  ,HH,'↓高'),COLORMAGENTA;

DRAWKLINE(H,O,L,C);


后台-系统-系统设置-扩展变量-(内容页告位2-手机版)
声明:本文内容由互联网用户自发贡献自行上传,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任。如果您发现有涉嫌版权的内容,欢迎发送邮件至本站联系邮箱进行举报,并提供相关证据,工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。
后台-系统-系统设置-扩展变量-(内容页告位3-手机版)